Pitt Ohio (pitd) Tracking Issues

Incident Report for Freight Engine

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 12:53 CDT

Investigating

Pitt Ohio is experiencing issues with their Tracking API. We are working with them to resolve the issue.
Posted Jun 04, 2026 - 16:09 CDT
This incident affected: Tracking.