Southeastern eBOLs are not returning.

Incident Report for Freight Engine

Resolved

SEFL eBOLs are returning, please contact our support team with any questions.
Posted Jul 21, 2025 - 15:38 CDT

Identified

SEFL is aware and investigating.
Posted Jul 21, 2025 - 15:01 CDT
This incident affected: eBOL.