R+L Rating is experiencing timeout issues.

Incident Report for Freight Engine

Resolved

R+L rates are returning, please contact our support team with any questions.
Posted Jul 21, 2025 - 15:19 CDT

Identified

R+L is investigating.
Posted Jul 21, 2025 - 14:34 CDT
This incident affected: Engine Platform.