FedEx Intermittent Tender and eBOL Issues

Incident Report for Freight Engine

Resolved

The intermittent issues with FedEx Tender and eBOL have been resolved.
Posted Jun 15, 2026 - 10:09 CDT

Monitoring

FedEx is experiencing intermittent issues with their tendering and eBOL services. We are working with them to resolve the issue.
Posted Jun 12, 2026 - 09:43 CDT
This incident affected: eBOL.