Old Dominion Freight Line Pickup Request Issues

Incident Report for Freight Engine

Resolved

The issues with Old Dominion Freight Line (ODFL) pickup requests have been resolved.
Posted Apr 24, 2026 - 10:23 CDT

Monitoring

Old Dominion Freight Line (ODFL) is experiencing issues with their pickup request service. We are working with them to resolve the issue.
Posted Apr 24, 2026 - 09:37 CDT
This incident affected: Pickup Requests.