API Dispatch Issues

Incident Report for Freight Engine

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:52 CDT

Investigating

Our Upstream Provider is Currently Experiencing Availability Issues
Posted Jun 12, 2025 - 13:31 CDT
This incident affected: Engine Platform and Pickup Requests.