Old Dominion- API Timeout Errors

Incident Report for Freight Engine

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 16:19 CDT

Identified

Old Dominion is currently experiencing API Time Out errors. They are aware, and are working to resolve.
Posted Jun 04, 2025 - 14:26 CDT
This incident affected: Volume Quotes.