AAA Cooper Service Disruptions

Incident Report for Freight Engine

Resolved

AAA Cooper services have stabilized and are now operational.
Posted Apr 22, 2026 - 10:08 CDT

Investigating

AAA Cooper is currently experiencing service disruptions affecting rating, pickup requests, and tracking. We are investigating the issue.
Posted Apr 22, 2026 - 09:21 CDT

Monitoring

AAA Cooper is currently experiencing service disruptions affecting rating, pickup requests, and tracking. We are investigating the issue.
Posted Apr 22, 2026 - 09:21 CDT
This incident affected: Engine Platform, Pickup Requests, and Tracking.