Magnum (mgul) - Rating & Pickup Requests Outage

Incident Report for Freight Engine

Resolved

Magnum's rating and pickup APIs have recovered and are operating normally.
Posted Aug 06, 2026 - 10:27 CDT

Investigating

Magnum is experiencing issues with their rating and pickup request APIs. We are working with them to resolve the issue.
Posted Aug 06, 2026 - 08:17 CDT
This incident affected: Pickup Requests.